1 Patch written by hhorak@, it should fix a segfault that happens when there are
2 holes due to deleted messages, this should fix both #584138 and #537694 (the
3 second as a side-effect), therefore the previous
4 upstream/537694-segv-imap-headers.patch is removed
6 This patch was retrieved from the original upstream bug
7 http://bugs.mutt.org/3288
14 char tempfile[_POSIX_PATH_MAX];
16 + int msgno, idx = msgbegin - 1;
19 int rc, mfhrc, oldmsgcount;
26 ctx->hdrs[idx] = imap_hcache_get (idata, h.data->uid);
31 dprint (2, (debugfile, "msg_fetch_header: ignoring fetch response with no body\n"));
37 /* make sure we don't get remnants from older larger message headers */
44 dprint (1, (debugfile, "imap_read_headers: skipping FETCH response for "