]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/537818-emptycharset.patch
sidebar patch applied, all old patches removed from series
[software/mutt-debian.git] / debian / patches / upstream / 537818-emptycharset.patch
1 without this patch mutt crashes if any option that contains charset is set to
2 empty, see upstream bug http://bugs.mutt.org/3326
3
4 --- a/init.c
5 +++ b/init.c
6 @@ -1732,6 +1732,9 @@
7    char *p, *q = NULL, *s = safe_strdup (val);
8    int rc = 0, strict = strcmp (opt->option, "send_charset") == 0;
9  
10 +  if (!s)
11 +    return rc;
12 +
13    for (p = strtok_r (s, ":", &q); p; p = strtok_r (NULL, ":", &q))
14    {
15      if (!*p)