]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/debian-specific/566076-build_doc_adjustments.patch
removing an article form the Description of mutt-patched to make lintian happy
[software/mutt-debian.git] / debian / patches / debian-specific / 566076-build_doc_adjustments.patch
1 Use w3m to build the txt manual
2
3 --- a/doc/Makefile.am
4 +++ b/doc/Makefile.am
5 @@ -102,9 +102,7 @@
6  
7  check:
8  manual.txt: manual.html
9 -       -LC_ALL=C lynx -dump -nolist -with_backspaces -display_charset=us-ascii manual.html > $@ || \
10 -       LC_ALL=C w3m -dump manual.html > $@ || \
11 -       LC_ALL=C elinks -dump -no-numbering -no-references manual.html | sed -e 's,\\001, ,g' > $@
12 +       LC_ALL=C w3m -dump -O UTF-8 manual.html > $@
13  
14  Muttrc: stamp-doc-rc
15  
16 @@ -116,10 +114,10 @@
17         touch stamp-doc-rc
18  
19  manual.html: $(srcdir)/html.xsl $(srcdir)/mutt.xsl stamp-doc-xml $(srcdir)/mutt.css
20 -       -xsltproc --nonet -o $@ $(srcdir)/html.xsl manual.xml
21 +       xsltproc --nonet -o $@ $(srcdir)/html.xsl manual.xml
22  
23  stamp-doc-chunked: $(srcdir)/chunk.xsl $(srcdir)/mutt.xsl stamp-doc-xml $(srcdir)/mutt.css
24 -       -xsltproc --nonet $(srcdir)/chunk.xsl manual.xml
25 +       xsltproc --nonet $(srcdir)/chunk.xsl manual.xml
26         touch stamp-doc-chunked
27  
28  $(CHUNKED_DOCFILES): stamp-doc-chunked