]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/578087-header-strchr.patch
removing an article form the Description of mutt-patched to make lintian happy
[software/mutt-debian.git] / debian / patches / upstream / 578087-header-strchr.patch
1 This fixes a segfault that can happen on a malformed message; patch comes from
2 upstream http://bugs.mutt.org/3483
3
4 --- a/sendlib.c
5 +++ b/sendlib.c
6 @@ -1799,7 +1799,7 @@
7    else
8    {
9      t = strchr (start, ':');
10 -    if (t > end)
11 +    if (!t || t > end)
12      {
13        dprint (1, (debugfile, "mwoh: warning: header not in "
14                   "'key: value' format!\n"));