]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/611410-no-implicit_autoview-for-text-html.patch
removing an article form the Description of mutt-patched to make lintian happy
[software/mutt-debian.git] / debian / patches / upstream / 611410-no-implicit_autoview-for-text-html.patch
1 This patch blacklist text/html from the list of documents that will be
2 shown automatically, the patch (the muttlib.c part) has been written by
3 Loïc Minier <lool@dooz.org>, I've added the documentation bit.
4
5 The patch has been forwarded upstream originally by Loïc on:
6 http://bugs.mutt.org/3496.
7
8 The original Debian bug for this problem is http://bugs.debian.org/611410
9
10 --- a/init.h
11 +++ b/init.h
12 @@ -1211,7 +1211,9 @@
13    ** ``\fCcopiousoutput\fP'' flag set for \fIevery\fP MIME attachment it doesn't have
14    ** an internal viewer defined for.  If such an entry is found, mutt will
15    ** use the viewer defined in that entry to convert the body part to text
16 -  ** form.
17 +  ** form. MIME attachments with 'text' types, with the only exception
18 +  ** of text/html, are excluded: they will be shown as they are unless auto_view
19 +  ** is specified.
20    */
21    { "include",         DT_QUAD, R_NONE, OPT_INCLUDE, M_ASKYES },
22    /*
23 --- a/muttlib.c
24 +++ b/muttlib.c
25 @@ -658,6 +658,9 @@
26    switch (m->type)
27    {
28      case TYPETEXT:
29 +      /* we don't want to display text/html */
30 +      if (!ascii_strcasecmp ("html", m->subtype))
31 +        return 1;
32        /* we can display any text, overridable by auto_view */
33        return 0;
34        break;