]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/620854-pop3-segfault.patch
removing an article form the Description of mutt-patched to make lintian happy
[software/mutt-debian.git] / debian / patches / upstream / 620854-pop3-segfault.patch
1 Fix a segfault that happens when $message_cachedir is set and a POP3 mailbox is
2 being opened, patch fetched from upstream bug http://bugs.mutt.org/3457
3
4 --- a/muttlib.c
5 +++ b/muttlib.c
6 @@ -1962,6 +1962,7 @@
7  {
8    char *p = safe_strdup (src);
9    int rc = mutt_convert_string (&p, Charset, "utf-8", 0);
10 -  strfcpy (dest, rc == 0 ? p : src, dlen);
11 +  /* `src' may be NULL, such as when called from the pop3 driver. */
12 +  strfcpy (dest, (rc == 0) ? NONULL(p) : NONULL(src), dlen);
13    FREE (&p);
14  }