]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/features-old/patch-1.5.4.vk.pgp_verbose_mime
upstream/548577-gpgme-1.2.patch: do not fail to open pgp signed message with libgpgme...
[software/mutt-debian.git] / debian / patches / features-old / patch-1.5.4.vk.pgp_verbose_mime
1 Enable pgp_mime_signature_filename and pgp_mime_signature_description
2
3 Index: mutt/globals.h
4 ===================================================================
5 --- mutt.orig/globals.h 2009-06-25 12:35:48.000000000 +0200
6 +++ mutt/globals.h      2009-06-25 12:36:22.000000000 +0200
7 @@ -242,6 +242,8 @@
8  WHERE char *PgpListSecringCommand;
9  WHERE char *PgpListPubringCommand;
10  WHERE char *PgpGetkeysCommand;
11 +WHERE char *PgpMimeSignatureFilename;
12 +WHERE char *PgpMimeSignatureDescription;
13  
14  /*-- formerly in smime.h --*/
15  WHERE char *SmimeDefaultKey;
16 Index: mutt/init.h
17 ===================================================================
18 --- mutt.orig/init.h    2009-06-25 12:35:48.000000000 +0200
19 +++ mutt/init.h 2009-06-25 12:36:22.000000000 +0200
20 @@ -2541,6 +2541,18 @@
21    ** a line quoted text if it also matches $$smileys. This mostly
22    ** happens at the beginning of a line.
23    */
24 +  { "pgp_mime_signature_filename", DT_STR, R_NONE, UL &PgpMimeSignatureFilename, UL "signature.asc"},
25 +  /*
26 +  ** .pp
27 +  ** This option sets the filename used for signature parts in PGP/MIME
28 +  ** signed messages.
29 +  */
30 +  { "pgp_mime_signature_description", DT_STR, R_NONE, UL &PgpMimeSignatureDescription, UL "Digital signature"},
31 +  /*
32 +  ** .pp
33 +  ** This option sets the Content-Description used for signature parts in
34 +  ** PGP/MIME signed messages.
35 +  */
36  
37  
38  
39 Index: mutt/pgp.c
40 ===================================================================
41 --- mutt.orig/pgp.c     2009-06-25 12:35:36.000000000 +0200
42 +++ mutt/pgp.c  2009-06-25 12:36:22.000000000 +0200
43 @@ -1131,6 +1131,8 @@
44    t->disposition = DISPINLINE;
45    t->encoding = ENC7BIT;
46    t->unlink = 1; /* ok to remove this file after sending. */
47 +  mutt_set_parameter ("name", PgpMimeSignatureFilename, &t->parameter);
48 +  t->description = safe_strdup (PgpMimeSignatureDescription);
49  
50    return (a);
51  }