]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/533370-pgp-inline.patch
upstream/548577-gpgme-1.2.patch: do not fail to open pgp signed message with libgpgme...
[software/mutt-debian.git] / debian / patches / upstream / 533370-pgp-inline.patch
1 inline pgp messages were displayed incorrectly when pgp_auto_decode=yes, see
2 upstream http://bugs.mutt.org/3269
3
4 --- a/crypt-gpgme.c
5 +++ b/crypt-gpgme.c
6 @@ -2371,16 +2371,14 @@
7                safe_fclose (&pgpout);
8              }
9          }
10 -#if 0
11        else
12        {
13 -        /* why would we want to display this at all? */
14 +        /* A traditional PGP part may mix signed and unsigned content */
15          /* XXX - we may wish to recode here */
16          if (s->prefix)
17            state_puts (s->prefix, s);
18          state_puts (buf, s);
19        }
20 -#endif
21      }
22  
23    m->goodsig = (maybe_goodsig && have_any_sigs);
24 --- a/pgp.c
25 +++ b/pgp.c
26 @@ -482,7 +482,6 @@
27           state_attach_puts (_("[-- END PGP SIGNED MESSAGE --]\n"), s);
28        }
29      }
30 -#if 0
31      else
32      {
33        /* why would we want to display this at all? */
34 @@ -491,7 +490,6 @@
35         state_puts (s->prefix, s);
36        state_puts (buf, s);
37      }
38 -#endif
39    }
40  
41    rc = 0;