]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/228671-pipe-mime.patch
upstream/311296-rand-mktemp.patch: more random file creation in /tmp, see CVE CAN...
[software/mutt-debian.git] / debian / patches / upstream / 228671-pipe-mime.patch
1 Don't draw imap fetch progress if we aren't in visual mode.
2 Drawing progress leaves terminal in confusing state when piping a message
3 from pager to less(1). See http://bugs.mutt.org/1771
4
5 --- a/imap/message.c
6 +++ b/imap/message.c
7 @@ -489,8 +489,9 @@
8             imap_error ("imap_fetch_message()", buf);
9             goto bail;
10           }
11 -         mutt_progress_init (&progressbar, _("Fetching message..."),
12 -                             M_PROGRESS_SIZE, NetInc, bytes);
13 +          if (!isendwin())
14 +           mutt_progress_init (&progressbar, _("Fetching message..."),
15 +                             M_PROGRESS_SIZE, NetInc, bytes);
16           if (imap_read_literal (msg->fp, idata, bytes, &progressbar) < 0)
17             goto bail;
18           /* pick up trailing line */