]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/538128-mh-folder-access.patch
upstream/311296-rand-mktemp.patch: more random file creation in /tmp, see CVE CAN...
[software/mutt-debian.git] / debian / patches / upstream / 538128-mh-folder-access.patch
1 this fixes a problem with new mail detection on MH folder, for a 
2 more detailed history see mutt bugs #3308 and #3312 and debian
3 bug 538128
4
5 --- a/mh.c
6 +++ b/mh.c
7 @@ -146,7 +146,7 @@
8    if ((p = strchr (t, '-')))
9    {
10      *p++ = '\0';
11 -    if (mutt_atoi (t, first) < 0 || mutt_atoi (t, last) < 0)
12 +    if (mutt_atoi (t, first) < 0 || mutt_atoi (p, last) < 0)
13        return -1;
14    }
15    else
16 @@ -167,7 +167,7 @@
17    size_t sz = 0;
18  
19    short f;
20 -  int first, last, rc;
21 +  int first, last, rc = 0;
22  
23    char pathname[_POSIX_PATH_MAX];
24    snprintf (pathname, sizeof (pathname), "%s/.mh_sequences", path);
25 @@ -207,7 +207,7 @@
26  out:
27    FREE (&buff);
28    safe_fclose (&fp);
29 -  return 0;
30 +  return rc;
31  }
32  
33  static inline mode_t mh_umask (CONTEXT* ctx)
34 @@ -238,6 +238,7 @@
35    for (i = 0; !r && i <= mhs.max; i++)
36      if (mhs_check (&mhs, i) & MH_SEQ_UNSEEN)
37        r = 1;
38 +  mhs_free_sequences (&mhs);
39    return r;
40  }
41  
42 @@ -1155,7 +1156,7 @@
43  
44    if (ctx->magic == M_MH)
45    {
46 -    if (mh_read_sequences (&mhs, ctx->path) >= 0)
47 +    if (mh_read_sequences (&mhs, ctx->path) < 0)
48        return -1;
49      mh_update_maildir (md, &mhs);
50      mhs_free_sequences (&mhs);