]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/533520-signature-highlight.patch
features/ifdef: fixed a typo (Closes: 539974), debian-specific/Muttrc: correctly...
[software/mutt-debian.git] / debian / patches / upstream / 533520-signature-highlight.patch
1 before this patch mutt failed to highlight some signatures if text_flowed was
2 set to yes (see upstream http://bugs.mutt.org/3275)
3
4 --- a/handler.c
5 +++ b/handler.c
6 @@ -1500,7 +1500,7 @@
7      l = mutt_strlen (buf);
8      if (l > 0 && buf[l-1] == '\n')
9        buf[--l] = 0;
10 -    if (option (OPTTEXTFLOWED))
11 +    if (mutt_strcmp (buf, "-- ") != 0 && option (OPTTEXTFLOWED))
12      {
13        while (l > 0 && buf[l-1] == ' ')
14         buf[--l] = 0;