1 diff -ruN mutt-1.5.9.orig/Muttrc.head.in mutt-1.5.9/Muttrc.head.in
2 --- mutt-1.5.9.orig/Muttrc.head.in 2002-01-24 13:10:47.000000000 +0100
3 +++ mutt-1.5.9/Muttrc.head.in 2005-04-10 13:54:02.000000000 +0200
6 ignore "from " received content- mime-version status x-status message-id
7 ignore sender references return-path lines
8 +ignore date delivered-to precedence errors-to in-reply-to user-agent
9 +ignore x-loop x-sender x-mailer x-msmail-priority x-mimeole x-ms- x-priority
10 +ignore x-accept-language x-authentication-warning thread- priority importance
11 +ignore x-original-to domainkey-signature
13 +# emacs-like bindings
14 +bind editor "\e<delete>" kill-word
15 +bind editor "\e<backspace>" kill-word
17 +# map delete-char to a sane value
18 +bind editor <delete> delete-char
20 +# some people actually like these settings
22 +#bind pager <up> previous-line
23 +#bind pager <down> next-line
25 +# don't add the hostname to the From header
27 +# don't generate a From header
30 +# Specifies how to sort messages in the index menu.
33 +# Exim does not remove Bcc headers
35 +# Postfix and qmail use Delivered-To for detecting loops
36 +unset bounce_delivered
38 +# weed out binary-only announcements to -devel-changes
39 +#macro index \CW T!~s\(.*source.*\)\nWn^T~A\n "Weed out binary-only announcements"
41 # imitate the old search-body function
42 macro index \eb '/~b ' 'search in message bodies'
44 macro pager \cb |urlview\n 'call urlview to extract URLs out of a message'
46 # Show documentation when pressing F1
47 -macro generic <f1> "!less @docdir@/manual.txt\n" "Show Mutt documentation"
48 -macro index <f1> "!less @docdir@/manual.txt\n" "Show Mutt documentation"
49 -macro pager <f1> "!less @docdir@/manual.txt\n" "Show Mutt documentation"
50 +macro generic <f1> "!zcat @docdir@/mutt/manual.txt.gz | sensible-pager\n" "Show Mutt documentation"
51 +macro index <f1> "!zcat @docdir@/mutt/manual.txt.gz | sensible-pager\n" "Show Mutt documentation"
52 +macro pager <f1> "!zcat @docdir@/mutt/manual.txt.gz | sensible-pager\n" "Show Mutt documentation"
54 +# Use folders which match on \\.gz$ or \\.bz2$ as [gb]zipped folders:
55 +open-hook \\.gz$ "gzip -cd %f > %t"
56 +close-hook \\.gz$ "gzip -c %t > %f"
57 +append-hook \\.gz$ "gzip -c %t >> %f"
58 +open-hook \\.bz2$ "bzip2 -cd %f > %t"
59 +close-hook \\.bz2$ "bzip2 -c %t > %f"
60 +append-hook \\.bz2$ "bzip2 -c %t >> %f"
62 # If Mutt is unable to determine your site's domain name correctly, you can
63 # set the default here.
72 +color normal white black
73 +color attachment brightyellow black
74 +color hdrdefault cyan black
75 +color indicator black cyan
76 +color markers brightred black
77 +color quoted green black
78 +color signature cyan black
79 +color status brightgreen blue
80 +color tilde blue black
82 +#color header brightgreen black ^From:
83 +#color header brightcyan black ^To:
84 +#color header brightcyan black ^Reply-To:
85 +#color header brightcyan black ^Cc:
86 +#color header brightblue black ^Subject:
87 +#color body brightred black [\-\.+_a-zA-Z0-9]+@[\-\.a-zA-Z0-9]+
88 +#color body brightblue black (https?|ftp)://[\-\.,/%~_:?&=\#a-zA-Z0-9]+