]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/568295-references.patch
debian/patches/compressed-folders: remove partially uncompressed folder if the open...
[software/mutt-debian.git] / debian / patches / upstream / 568295-references.patch
1 The purpose of this patch is to preserve the References header if the
2 In-Reply-To header is not initially present; forwarded upstream to
3 http://bugs.mutt.org/3378
4
5 --- a/headers.c
6 +++ b/headers.c
7 @@ -114,8 +114,8 @@
8       $edit_headers set, we remove References: as they're likely invalid;
9       we can simply compare strings as we don't generate References for
10       multiple Message-Ids in IRT anyways */
11 -  if (!n->in_reply_to || (msg->env->in_reply_to &&
12 -                         mutt_strcmp (n->in_reply_to->data,
13 +  if (msg->env->in_reply_to &&
14 +     (!n->in_reply_to || mutt_strcmp (n->in_reply_to->data,
15                                        msg->env->in_reply_to->data) != 0))
16      mutt_free_list (&msg->env->references);
17