]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/debian-specific/document_debian_defaults
refresh compressed-folders patch
[software/mutt-debian.git] / debian / patches / debian-specific / document_debian_defaults
1 Index: debian-mutt/init.h
2 ===================================================================
3 --- debian-mutt.orig/init.h     2007-03-24 17:54:00.000000000 +0100
4 +++ debian-mutt/init.h  2007-03-24 18:00:57.000000000 +0100
5 @@ -289,6 +289,9 @@ struct option_t MuttVars[] = {
6    ** .pp
7    ** When this variable is set, mutt will include Delivered-To headers when
8    ** bouncing messages.  Postfix users may wish to unset this variable.
9 +  ** .pp
10 +  ** \fBNote:\fP On Debian systems, this option is unset by default in
11 +  ** /etc/Muttrc.
12    */
13    { "braille_friendly", DT_BOOL, R_NONE, OPTBRAILLEFRIENDLY, 0 },
14    /*
15 @@ -798,6 +801,9 @@ struct option_t MuttVars[] = {
16    ** Specifies the hostname to use after the ``@'' in local e-mail
17    ** addresses.  This overrides the compile time definition obtained from
18    ** /etc/resolv.conf.
19 +  ** .pp
20 +  ** \fBNote:\fP On Debian systems, the default for this variable is obtained
21 +  ** from /etc/mailname when Mutt starts.
22    */
23    { "ignore_linear_white_space",    DT_BOOL, R_NONE, OPTIGNORELWS, 0 },
24    /*
25 @@ -1301,6 +1307,9 @@ struct option_t MuttVars[] = {
26    ** system.  It is used with various sets of parameters to gather the
27    ** list of known remailers, and to finally send a message through the
28    ** mixmaster chain.
29 +  ** .pp
30 +  ** \fBNote:\fP On Debian systems, this option is set by default to
31 +  ** ``mixmaster-filter'' in /etc/Muttrc.
32    */
33  #endif
34  
35 @@ -1843,6 +1852,10 @@ struct option_t MuttVars[] = {
36    ** This variable contains the name of either a directory, or a file which
37    ** contains trusted certificates for use with OpenSSL.
38    ** (S/MIME only)
39 +  ** .pp
40 +  ** \fBNote:\fP On Debian systems, this defaults to the first existing file in
41 +  ** the following list: ~/.smime/ca-certificates.crt ~/.smime/ca-bundle.crt
42 +  ** /etc/ssl/certs/ca-certificates.crt.
43    */
44    { "smime_certificates",      DT_PATH, R_NONE, UL &SmimeCertificates, 0 },
45    /*
46 @@ -2049,6 +2062,9 @@ struct option_t MuttVars[] = {
47    ** certificates are also automatically accepted.
48    ** .pp
49    ** Example: set ssl_ca_certificates_file=/etc/ssl/certs/ca-certificates.crt
50 +  ** .pp
51 +  ** \fBNote:\fP On Debian systems, this variable defaults to the example
52 +  ** mentioned. This file is managed by the ``ca-certificates'' package.
53    */
54  # endif /* USE_SSL_GNUTLS */
55  #endif /* defined(USE_SSL) */
56 @@ -2626,6 +2642,9 @@ struct option_t MuttVars[] = {
57    ** .pp
58    ** You may optionally use the reverse- prefix to specify reverse sorting
59    ** order (example: set sort=reverse-date-sent).
60 +  ** .pp
61 +  ** \fBNote:\fP On Debian systems, this option is set by default to
62 +  ** ``threads'' in /etc/Muttrc.
63    */
64    { "sort_alias",      DT_SORT|DT_SORT_ALIAS,  R_NONE, UL &SortAlias, SORT_ALIAS },
65    /*
66 @@ -3022,6 +3041,9 @@ struct option_t MuttVars[] = {
67    ** is set to deliver directly via SMTP (see ``$$smtp_url''), this
68    ** option does nothing: mutt will never write out the BCC header
69    ** in this case.
70 +  ** .pp
71 +  ** \fBNote:\fP On Debian systems, exim4 and postfix strip BCC headers by
72 +  ** default. The above warning applies to exim3 users, see /etc/Muttrc.
73    */
74    {"xterm_icon",       DT_STR,   R_BOTH, UL &XtermIcon,  UL "M%?n?AIL&ail?"},
75    /*