]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/debian-specific/529838-gnutls-autoconf.patch
use pkg-config to detect gnutls, closes 529838
[software/mutt-debian.git] / debian / patches / debian-specific / 529838-gnutls-autoconf.patch
1 More details about this patch are on http://bugs.debian.org/529838
2 The bug and the patch were forwarded to upstream, please see 
3 http://bugs.mutt.org/3239
4
5 --- a/configure.ac
6 +++ b/configure.ac
7 @@ -690,10 +690,10 @@
8    then
9      AC_MSG_WARN([SSL support is only useful with POP, IMAP or SMTP support])
10    else
11 -    MUTT_AM_PATH_GNUTLS([$gnutls_prefix],
12 +    PKG_CHECK_MODULES(GNUTLS, gnutls,
13        [dnl GNUTLS found
14 -      CPPFLAGS="$CPPFLAGS $LIBGNUTLS_CFLAGS"
15 -      MUTTLIBS="$MUTTLIBS $LIBGNUTLS_LIBS"
16 +      CPPFLAGS="$CPPFLAGS $GNUTLS_CFLAGS"
17 +      MUTTLIBS="$MUTTLIBS $GNUTLS_LIBS"
18  
19        AC_DEFINE(USE_SSL,1,[ Define if you want support for SSL. ])
20        AC_DEFINE(USE_SSL_GNUTLS,1,[ Define if you want support for SSL via GNUTLS. ])