]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/misc/autotools-update.diff
mutt (1.5.15+20070412-1) experimental; urgency=low
[software/mutt-debian.git] / debian / patches / misc / autotools-update.diff
1 Index: mutt/Makefile.in
2 ===================================================================
3 --- mutt.orig/Makefile.in       2007-03-13 20:40:30.000000000 +0100
4 +++ mutt/Makefile.in    2007-03-13 21:08:37.000000000 +0100
5 @@ -73,10 +73,10 @@ am__objects_1 = patchlist.$(OBJEXT)
6  am_mutt_OBJECTS = $(am__objects_1) addrbook.$(OBJEXT) alias.$(OBJEXT) \
7         attach.$(OBJEXT) base64.$(OBJEXT) browser.$(OBJEXT) \
8         buffy.$(OBJEXT) color.$(OBJEXT) crypt.$(OBJEXT) \
9 -       cryptglue.$(OBJEXT) commands.$(OBJEXT) complete.$(OBJEXT) \
10 -       compose.$(OBJEXT) copy.$(OBJEXT) curs_lib.$(OBJEXT) \
11 -       curs_main.$(OBJEXT) date.$(OBJEXT) edit.$(OBJEXT) \
12 -       enter.$(OBJEXT) flags.$(OBJEXT) init.$(OBJEXT) \
13 +       cryptglue.$(OBJEXT) compress.$(OBJEXT) commands.$(OBJEXT) \
14 +       complete.$(OBJEXT) compose.$(OBJEXT) copy.$(OBJEXT) \
15 +       curs_lib.$(OBJEXT) curs_main.$(OBJEXT) date.$(OBJEXT) \
16 +       edit.$(OBJEXT) enter.$(OBJEXT) flags.$(OBJEXT) init.$(OBJEXT) \
17         filter.$(OBJEXT) from.$(OBJEXT) getdomain.$(OBJEXT) \
18         group.$(OBJEXT) handler.$(OBJEXT) hash.$(OBJEXT) \
19         hdrline.$(OBJEXT) headers.$(OBJEXT) help.$(OBJEXT) \
20 @@ -301,7 +301,7 @@ bin_SCRIPTS = muttbug flea @SMIMEAUX_TAR
21  BUILT_SOURCES = keymap_defs.h patchlist.c
22  mutt_SOURCES = $(BUILT_SOURCES) \
23         addrbook.c alias.c attach.c base64.c browser.c buffy.c color.c \
24 -       crypt.c cryptglue.c \
25 +       crypt.c cryptglue.c compress.c \
26         commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
27         edit.c enter.c flags.c init.c filter.c from.c \
28         getdomain.c group.c \
29 @@ -334,7 +334,7 @@ EXTRA_mutt_SOURCES = account.c md5c.c mu
30         utf8.c wcwidth.c 
31  
32  EXTRA_DIST = COPYRIGHT GPL OPS OPS.PGP OPS.CRYPT OPS.SMIME TODO UPDATING \
33 -       configure account.h \
34 +       configure account.h compress.h \
35         attach.h buffy.h charset.h copy.h crypthash.h dotlock.h functions.h gen_defs \
36         globals.h hash.h history.h init.h keymap.h mutt_crypt.h \
37         mailbox.h mapping.h md5.h mime.h mutt.h mutt_curses.h mutt_menu.h \
38 @@ -506,6 +506,7 @@ distclean-compile:
39  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/commands.Po@am__quote@
40  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/complete.Po@am__quote@
41  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compose.Po@am__quote@
42 +@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/compress.Po@am__quote@
43  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/copy.Po@am__quote@
44  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-gpgme.Po@am__quote@
45  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/crypt-mod-pgp-classic.Po@am__quote@
46 Index: mutt/config.h.in
47 ===================================================================
48 --- mutt.orig/config.h.in       2007-03-12 19:15:58.000000000 +0100
49 +++ mutt/config.h.in    2007-03-13 21:08:09.000000000 +0100
50 @@ -513,6 +513,9 @@
51  /* Define to enable Sun mailtool attachments support. */
52  #undef SUN_ATTACHMENT
53  
54 +/* Define to support compressed folders. */
55 +#undef USE_COMPRESSED
56 +
57  /* Define to use dotlocking for mailboxes. */
58  #undef USE_DOTLOCK
59  
60 Index: mutt/configure
61 ===================================================================
62 --- mutt.orig/configure 2007-03-13 20:40:37.000000000 +0100
63 +++ mutt/configure      2007-03-13 21:08:33.000000000 +0100
64 @@ -1367,6 +1367,7 @@ Optional Features:
65    --enable-buffy-size     Use file size attribute instead of access time
66    --enable-mailtool       Enable Sun mailtool attachments support
67    --enable-locales-fix    The result of isprint() is unreliable
68 +  --enable-compressed     Enable compressed folders support
69    --enable-exact-address  Enable regeneration of email addresses
70    --enable-hcache         Enable header caching
71    --disable-iconv         Disable iconv support
72 @@ -15489,6 +15490,18 @@ _ACEOF
73  fi
74  
75  
76 +# Check whether --enable-compressed was given.
77 +if test "${enable_compressed+set}" = set; then
78 +  enableval=$enable_compressed; if test x$enableval = xyes; then
79 +
80 +cat >>confdefs.h <<\_ACEOF
81 +#define USE_COMPRESSED 1
82 +_ACEOF
83 +
84 +        fi
85 +fi
86 +
87 +
88  
89  # Check whether --with-exec-shell was given.
90  if test "${with_exec_shell+set}" = set; then