3 * 2009-01-15 myon: refreshed for mutt-1.5.19; drop our list of ignored headers
4 in favor of upstream's new unignore list
8 @@ -12,6 +12,32 @@ unignore from: subject to cc date x-mail
9 # Display the fields in this order
10 hdr_order date from to cc subject
12 +# emacs-like bindings
13 +bind editor "\e<delete>" kill-word
14 +bind editor "\e<backspace>" kill-word
16 +# map delete-char to a sane value
17 +bind editor <delete> delete-char
19 +# some people actually like these settings
21 +#bind pager <up> previous-line
22 +#bind pager <down> next-line
24 +# Specifies how to sort messages in the index menu.
27 +# Uncomment if your MTA does not strip Bcc: headers.
28 +# (exim4 and postfix strip them, exim(3) does not.)
30 +# Postfix and qmail use Delivered-To for detecting loops
31 +unset bounce_delivered
33 +set mixmaster="mixmaster-filter"
35 +# System-wide CA file managed by the ca-certificates package
36 +set ssl_ca_certificates_file="/etc/ssl/certs/ca-certificates.crt"
38 # imitate the old search-body function
39 macro index \eb "<search>~b " "search in message bodies"
41 @@ -23,7 +49,7 @@ macro index,pager,attach,compose \cb "\
42 "call urlview to extract URLs out of a message"
44 # Show documentation when pressing F1
45 -macro generic,pager <F1> "<shell-escape> less @docdir@/manual.txt<Enter>" "show Mutt documentation"
46 +macro generic,pager <F1> "<shell-escape> zcat @docdir@/mutt/manual.txt.gz | sensible-pager<enter>" "show Mutt documentation"
48 # show the incoming mailboxes list (just like "mutt -y") and back when pressing "y"
49 macro index,pager y "<change-folder>?<toggle-mailboxes>" "show incoming mailboxes list"
50 @@ -35,7 +61,7 @@ bind browser y exit
51 # append-hook \\.gz$ "gzip -c %t >> %f"
53 # If Mutt is unable to determine your site's domain name correctly, you can
54 -# set the default here.
55 +# set the default here. (better: fix /etc/mailname)
57 # set hostname=cs.hmc.edu
59 @@ -101,6 +127,9 @@ attachments +I text/plain
60 attachments -A message/external-body
61 attachments -I message/external-body
63 +# enable mime lookup by extension
64 +mime_lookup application/octet-stream