]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/debian-specific/build_doc_adjustments.diff
added a patch to correctly parse the IMAP url (Closes: 534543)
[software/mutt-debian.git] / debian / patches / debian-specific / build_doc_adjustments.diff
1 Use elinks(1) to generate the HTML manual page
2
3 --- a/doc/Makefile.am
4 +++ b/doc/Makefile.am
5 @@ -100,9 +100,7 @@ uninstall-local:
6  
7  check:
8  manual.txt: manual.html
9 -       -LC_ALL=C lynx -dump -nolist -with_backspaces manual.html > $@ || \
10 -       LC_ALL=C w3m -dump manual.html > $@ || \
11 -       LC_ALL=C elinks -dump -no-numbering -no-references manual.html | sed -e 's,\\001, ,g' > $@
12 +       LC_ALL=C elinks -dump -dump-charset utf8 -no-numbering -no-references $< > $@
13  
14  Muttrc: stamp-doc-rc
15  
16 @@ -114,10 +112,10 @@ stamp-doc-rc: $(top_srcdir)/init.h maked
17         touch stamp-doc-rc
18  
19  manual.html: $(srcdir)/html.xsl $(srcdir)/mutt.xsl stamp-doc-xml $(srcdir)/mutt.css
20 -       -xsltproc --nonet -o $@ $(srcdir)/html.xsl manual.xml
21 +       xsltproc --nonet -o $@ $(srcdir)/html.xsl manual.xml
22  
23  stamp-doc-chunked: $(srcdir)/chunk.xsl $(srcdir)/mutt.xsl stamp-doc-xml $(srcdir)/mutt.css
24 -       -xsltproc --nonet $(srcdir)/chunk.xsl manual.xml
25 +       xsltproc --nonet $(srcdir)/chunk.xsl manual.xml
26         touch stamp-doc-chunked
27  
28  $(CHUNKED_DOCFILES): stamp-doc-chunked