]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/misc/smime_keys-manpage.patch
added a patch to correctly parse the IMAP url (Closes: 534543)
[software/mutt-debian.git] / debian / patches / misc / smime_keys-manpage.patch
1 add a missing manpage for smime_keys
2 see upstream CR #3272
3
4 Index: mutt/doc/Makefile.am
5 ===================================================================
6 --- mutt.orig/doc/Makefile.am   2009-06-25 12:35:40.000000000 +0200
7 +++ mutt/doc/Makefile.am        2009-06-25 12:36:48.000000000 +0200
8 @@ -10,6 +10,7 @@
9  noinst_PROGRAMS = makedoc
10  
11  EXTRA_DIST = dotlock.man               \
12 +        smime_keys.man                  \
13         muttbug.man                     \
14         mutt.man                        \
15         PGP-Notes.txt                   \
16 @@ -45,13 +46,14 @@
17  
18  all: makedoc-all
19  
20 -makedoc-all: mutt.1 muttrc.man manual.html stamp-doc-rc stamp-doc-chunked manual.txt
21 +makedoc-all: mutt.1 smime_keys.1 muttrc.man manual.html stamp-doc-rc stamp-doc-chunked manual.txt
22  
23  install-data-local: makedoc-all instdoc
24         $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/man1
25         $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/man5
26         $(top_srcdir)/mkinstalldirs $(DESTDIR)$(sysconfdir)
27         ./instdoc mutt.1 $(DESTDIR)$(mandir)/man1/mutt.1
28 +       ./instdoc smime_keys.1 $(DESTDIR)$(mandir)/man1/smime_keys.1
29         ./instdoc $(srcdir)/muttbug.man $(DESTDIR)$(mandir)/man1/flea.1
30         ./instdoc $(srcdir)/muttbug.man $(DESTDIR)$(mandir)/man1/muttbug.1
31         test x@DOTLOCK_TARGET@ = x || ./instdoc $(srcdir)/dotlock.man \
32 @@ -80,7 +82,7 @@
33         fi
34  
35  uninstall-local:
36 -       for f in mutt.1 mutt_dotlock.1 flea.1 muttbug.1 ; do \
37 +       for f in mutt.1 mutt_dotlock.1 flea.1 muttbug.1 smime_keys.1; do \
38                 rm -f $(DESTDIR)$(mandir)/man1/$$f ; \
39         done
40         for f in muttrc.5 mbox.5 mmdf.5 ; do \
41 @@ -142,7 +144,7 @@
42         rm -rf vars.tmp.1 vars.tmp.2
43  
44  clean-local:
45 -       rm -f *~ *.html *.orig *.rej  stamp-doc-* *.ps mutt.1 muttrc.man
46 +       rm -f *~ *.html *.orig *.rej  stamp-doc-* *.ps mutt.1 smime_keys.1 muttrc.man
47         rm -f *.aux *.log *.tex *.out
48  
49  DISTCLEANFILES=manual.txt manual.html manual.xml manual.pdf html \
50 @@ -166,6 +168,9 @@
51  mutt.1: $(srcdir)/mutt.man
52         $(EDIT) $(srcdir)/mutt.man > $@
53  
54 +smime_keys.1: $(srcdir)/smime_keys.man
55 +       $(EDIT) $(srcdir)/smime_keys.man > $@
56 +
57  stamp-doc-xml: makedoc$(EXEEXT) $(top_srcdir)/init.h \
58                 manual.xml.head $(top_srcdir)/functions.h $(top_srcdir)/OPS* manual.xml.tail \
59                 $(srcdir)/gen-map-doc $(top_srcdir)/VERSION $(top_srcdir)/ChangeLog
60 Index: mutt/doc/smime_keys.man
61 ===================================================================
62 --- /dev/null   1970-01-01 00:00:00.000000000 +0000
63 +++ mutt/doc/smime_keys.man     2009-06-25 12:36:48.000000000 +0200
64 @@ -0,0 +1,69 @@
65 +.\" -*-nroff-*-
66 +.\"
67 +.\"
68 +.\"     Copyright (C) 2001,2002 Oliver Ehli <elmy@acm.org>
69 +.\"     Copyright (C) 2001 Mike Schiraldi <raldi@research.netsol.com>
70 +.\"     Copyright (C) 2003 Bjoern Jacke <bjoern@j3e.de>
71 +.\"
72 +.\"     This program is free software; you can redistribute it and/or modify
73 +.\"     it under the terms of the GNU General Public License as published by
74 +.\"     the Free Software Foundation; either version 2 of the License, or
75 +.\"     (at your option) any later version.
76 +.\"
77 +.\"     This program is distributed in the hope that it will be useful,
78 +.\"     but WITHOUT ANY WARRANTY; without even the implied warranty of
79 +.\"     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
80 +.\"     GNU General Public License for more details.
81 +.\"
82 +.\"     You should have received a copy of the GNU General Public License
83 +.\"     along with this program; if not, write to the Free Software
84 +.\"     Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA.
85 +.\"
86 +.TH smime_keys 1 "May 2009" Unix "User Manuals"
87 +.SH "NAME"
88 +smime_keys \- Utility to add S/MIME certificate to the internal database used by mutt
89 +.SH SYNOPSIS
90 +.PP
91 +.B smime_keys
92 +<operation>  [file(s) | keyID [file(s)]]
93 +.SH "DESCRIPTION"
94 +The purpose of this tool is to manipulate the internal database of S/MIME certificates
95 +used by mutt to sign mail messages which will be sent or to verify mail messages received
96 +and signed with S/MIME
97 +.SH OPTIONS
98 +.PP
99 +.IP \fBinit\fP
100 +no files needed, inits directory structure.
101 +.IP \fBlist\fP
102 +lists the certificates stored in database.
103 +.IP \fBlabel\fP
104 +keyID required. changes/removes/adds label.
105 +.IP \fBremove\fP
106 +keyID required.
107 +.IP \fBverify\fP
108 +1=keyID and optionally 2=CRL
109 +Verifies the certificate chain, and optionally wether
110 +this certificate is included in supplied CRL (PEM format).
111 +Note: to verify all certificates at the same time,
112 +replace keyID with "all"
113 +.IP \fBadd_cert\fP
114 +certificate required.
115 +.IP \fBadd_chain\fP
116 +three files reqd: 1=Key, 2=certificate
117 +plus 3=intermediate certificate(s).
118 +.IP \fBadd_p12\fP
119 +one file reqd. Adds keypair to database.
120 +file is PKCS12 (e.g. export from netscape).
121 +.IP \fBadd_pem\fP
122 +one file reqd. Adds keypair to database.
123 +(file was converted from e.g. PKCS12).
124 +.IP \fBadd_root\fP
125 +one file reqd. Adds PEM root certificate to the location
126 +specified within muttrc (smime_verify_* command)
127 +.SH NO WARRANTIES
128 +This program is distributed in the hope that it will be useful,
129 +but WITHOUT ANY WARRANTY; without even the implied warranty of
130 +MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
131 +GNU General Public License for more details.
132 +.PP
133 +Mutt Home Page: http://www.mutt.org/