]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/misc/smime_keys-manpage.patch
Merge branch '1.5.20-1+fix533439-atime'
[software/mutt-debian.git] / debian / patches / misc / smime_keys-manpage.patch
1 add a missing manpage for smime_keys
2 see upstream CR #3272
3
4 --- a/doc/Makefile.am
5 +++ b/doc/Makefile.am
6 @@ -10,6 +10,7 @@
7  noinst_PROGRAMS = makedoc
8  
9  EXTRA_DIST = dotlock.man               \
10 +        smime_keys.man                  \
11         muttbug.man                     \
12         mutt.man                        \
13         PGP-Notes.txt                   \
14 @@ -45,13 +46,14 @@
15  
16  all: makedoc-all
17  
18 -makedoc-all: mutt.1 muttrc.man manual.html stamp-doc-rc stamp-doc-chunked manual.txt
19 +makedoc-all: mutt.1 smime_keys.1 muttrc.man manual.html stamp-doc-rc stamp-doc-chunked manual.txt
20  
21  install-data-local: makedoc-all instdoc
22         $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/man1
23         $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/man5
24         $(top_srcdir)/mkinstalldirs $(DESTDIR)$(sysconfdir)
25         ./instdoc mutt.1 $(DESTDIR)$(mandir)/man1/mutt.1
26 +       ./instdoc smime_keys.1 $(DESTDIR)$(mandir)/man1/smime_keys.1
27         ./instdoc $(srcdir)/muttbug.man $(DESTDIR)$(mandir)/man1/flea.1
28         ./instdoc $(srcdir)/muttbug.man $(DESTDIR)$(mandir)/man1/muttbug.1
29         test x@DOTLOCK_TARGET@ = x || ./instdoc $(srcdir)/dotlock.man \
30 @@ -80,7 +82,7 @@
31         fi
32  
33  uninstall-local:
34 -       for f in mutt.1 mutt_dotlock.1 flea.1 muttbug.1 ; do \
35 +       for f in mutt.1 mutt_dotlock.1 flea.1 muttbug.1 smime_keys.1; do \
36                 rm -f $(DESTDIR)$(mandir)/man1/$$f ; \
37         done
38         for f in muttrc.5 mbox.5 mmdf.5 ; do \
39 @@ -145,7 +147,7 @@
40         rm -rf vars.tmp.1 vars.tmp.2
41  
42  clean-local:
43 -       rm -f *~ *.html *.orig *.rej  stamp-doc-* *.ps mutt.1 muttrc.man
44 +       rm -f *~ *.html *.orig *.rej  stamp-doc-* *.ps mutt.1 smime_keys.1 muttrc.man
45         rm -f *.aux *.log *.tex *.out
46  
47  DISTCLEANFILES=manual.txt manual.html manual.xml manual.pdf html \
48 @@ -169,6 +171,9 @@
49  mutt.1: $(srcdir)/mutt.man
50         $(EDIT) $(srcdir)/mutt.man > $@
51  
52 +smime_keys.1: $(srcdir)/smime_keys.man
53 +       $(EDIT) $(srcdir)/smime_keys.man > $@
54 +
55  stamp-doc-xml: makedoc$(EXEEXT) $(top_srcdir)/init.h \
56                 manual.xml.head $(top_srcdir)/functions.h $(top_srcdir)/OPS* manual.xml.tail \
57                 $(srcdir)/gen-map-doc $(top_srcdir)/VERSION $(top_srcdir)/ChangeLog
58 --- /dev/null
59 +++ b/doc/smime_keys.man
60 @@ -0,0 +1,69 @@
61 +.\" -*-nroff-*-
62 +.\"
63 +.\"
64 +.\"     Copyright (C) 2001,2002 Oliver Ehli <elmy@acm.org>
65 +.\"     Copyright (C) 2001 Mike Schiraldi <raldi@research.netsol.com>
66 +.\"     Copyright (C) 2003 Bjoern Jacke <bjoern@j3e.de>
67 +.\"
68 +.\"     This program is free software; you can redistribute it and/or modify
69 +.\"     it under the terms of the GNU General Public License as published by
70 +.\"     the Free Software Foundation; either version 2 of the License, or
71 +.\"     (at your option) any later version.
72 +.\"
73 +.\"     This program is distributed in the hope that it will be useful,
74 +.\"     but WITHOUT ANY WARRANTY; without even the implied warranty of
75 +.\"     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
76 +.\"     GNU General Public License for more details.
77 +.\"
78 +.\"     You should have received a copy of the GNU General Public License
79 +.\"     along with this program; if not, write to the Free Software
80 +.\"     Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301, USA.
81 +.\"
82 +.TH smime_keys 1 "May 2009" Unix "User Manuals"
83 +.SH "NAME"
84 +smime_keys \- Utility to add S/MIME certificate to the internal database used by mutt
85 +.SH SYNOPSIS
86 +.PP
87 +.B smime_keys
88 +<operation>  [file(s) | keyID [file(s)]]
89 +.SH "DESCRIPTION"
90 +The purpose of this tool is to manipulate the internal database of S/MIME certificates
91 +used by mutt to sign mail messages which will be sent or to verify mail messages received
92 +and signed with S/MIME
93 +.SH OPTIONS
94 +.PP
95 +.IP \fBinit\fP
96 +no files needed, inits directory structure.
97 +.IP \fBlist\fP
98 +lists the certificates stored in database.
99 +.IP \fBlabel\fP
100 +keyID required. changes/removes/adds label.
101 +.IP \fBremove\fP
102 +keyID required.
103 +.IP \fBverify\fP
104 +1=keyID and optionally 2=CRL
105 +Verifies the certificate chain, and optionally wether
106 +this certificate is included in supplied CRL (PEM format).
107 +Note: to verify all certificates at the same time,
108 +replace keyID with "all"
109 +.IP \fBadd_cert\fP
110 +certificate required.
111 +.IP \fBadd_chain\fP
112 +three files reqd: 1=Key, 2=certificate
113 +plus 3=intermediate certificate(s).
114 +.IP \fBadd_p12\fP
115 +one file reqd. Adds keypair to database.
116 +file is PKCS12 (e.g. export from netscape).
117 +.IP \fBadd_pem\fP
118 +one file reqd. Adds keypair to database.
119 +(file was converted from e.g. PKCS12).
120 +.IP \fBadd_root\fP
121 +one file reqd. Adds PEM root certificate to the location
122 +specified within muttrc (smime_verify_* command)
123 +.SH NO WARRANTIES
124 +This program is distributed in the hope that it will be useful,
125 +but WITHOUT ANY WARRANTY; without even the implied warranty of
126 +MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
127 +GNU General Public License for more details.
128 +.PP
129 +Mutt Home Page: http://www.mutt.org/