]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/514960-certificate-insecure-algorithm.patch
upstream/603288-split-fetches.patch: split FETCH's into smaller chunks, workaround...
[software/mutt-debian.git] / debian / patches / upstream / 514960-certificate-insecure-algorithm.patch
1 The new version of gnutls introduced this new option which mutt did not 
2 know about, if the cert is signed with an insecure algorithm (md5) it will
3 set a particular bit; if the cert is in the cache of the user we will
4 unset all bits so this has to be unset as well
5 See http://bugs.mutt.org/3229 and http://bugs.debian.org/514960
6
7 --- a/mutt_ssl_gnutls.c
8 +++ b/mutt_ssl_gnutls.c
9 @@ -614,6 +614,13 @@
10         in our cache. */
11        certstat ^= GNUTLS_CERT_SIGNER_NOT_CA;
12      }
13 +
14 +    if (certstat & GNUTLS_CERT_INSECURE_ALGORITHM)
15 +    {
16 +      /* if the certificate is in the cache the user is happy with
17 +         using an insecure algorithm */
18 +      certstat ^= GNUTLS_CERT_INSECURE_ALGORITHM;
19 +    }
20    }
21  
22    if (certstat & GNUTLS_CERT_REVOKED)