1 The new version of gnutls introduced this new option which mutt did not
2 know about, if the cert is signed with an insecure algorithm (md5) it will
3 set a particular bit; if the cert is in the cache of the user we will
4 unset all bits so this has to be unset as well
5 See http://bugs.mutt.org/3229 and http://bugs.debian.org/514960
7 --- a/mutt_ssl_gnutls.c
8 +++ b/mutt_ssl_gnutls.c
11 certstat ^= GNUTLS_CERT_SIGNER_NOT_CA;
14 + if (certstat & GNUTLS_CERT_INSECURE_ALGORITHM)
16 + /* if the certificate is in the cache the user is happy with
17 + using an insecure algorithm */
18 + certstat ^= GNUTLS_CERT_INSECURE_ALGORITHM;
22 if (certstat & GNUTLS_CERT_REVOKED)