]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/528233-readonly-open.patch
adding the upstream bugs in the patch descriptions
[software/mutt-debian.git] / debian / patches / upstream / 528233-readonly-open.patch
1 Open attachments as read-only so the editor won't be able to modify it;
2 otherwise the user can believe that he/she can edit it and risk to lose his/her
3 work (see upstream bug http://bugs.mutt.org/3261)
4
5 #528233, updated in #572203
6
7 --- a/attach.c
8 +++ b/attach.c
9 @@ -492,6 +492,7 @@ int mutt_view_attachment (FILE *fp, BODY
10        FREE (&fname);
11        if (mutt_save_attachment (fp, a, tempfile, 0, NULL) == -1)
12         goto return_error;
13 +      chmod (tempfile, 0400);
14      }
15  
16      use_pipe = rfc1524_expand_command (a, tempfile, type,
17 @@ -633,7 +634,11 @@ int mutt_view_attachment (FILE *fp, BODY
18    if (entry)
19      rfc1524_free_entry (&entry);
20    if (fp && tempfile[0])
21 +  {
22 +    /* Restore write permission so mutt_unlink can open the file for writing */
23 +    chmod(tempfile, 0600);
24      mutt_unlink (tempfile);
25 +  }
26    else if (unlink_tempfile)
27      unlink(tempfile);
28