1 A workaround for Exchange 2010 IMAP protocol, tracked in
2 http://bugs.mutt.org/3459, already merged in the ubuntu version of mutt
9 fetchlast = msgend + 1;
10 + /* Microsoft Exchange 2010 violates the IMAP protocol and
11 + * starts omitting messages if one FETCHes more than 2047 (or
12 + * or somewhere around that number. We therefore split the
13 + * FETCH into chunks of 2000 messages each */
14 + if (fetchlast - msgno - 1 > 2000)
16 + fetchlast = msgno+1 + 2000;
19 safe_asprintf (&cmd, "FETCH %d:%d (UID FLAGS INTERNALDATE RFC822.SIZE %s)",
20 msgno + 1, fetchlast, hdrreq);
21 imap_cmd_start (idata, cmd);