]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/383769-score-match.patch
Add upstream/573823-imap_internal_date
[software/mutt-debian.git] / debian / patches / upstream / 383769-score-match.patch
1 better matching for ~f, same as mutt-ng did, see upstream
2 http://bugs.mutt.org/2179
3
4 --- a/score.c
5 +++ b/score.c
6 @@ -133,7 +133,7 @@
7    hdr->score = 0; /* in case of re-scoring */
8    for (tmp = Score; tmp; tmp = tmp->next)
9    {
10 -    if (mutt_pattern_exec (tmp->pat, 0, NULL, hdr) > 0)
11 +    if (mutt_pattern_exec (tmp->pat, M_MATCH_FULL_ADDRESS, NULL, hdr) > 0)
12      {
13        if (tmp->exact || tmp->val == 9999 || tmp->val == -9999)
14        {