]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/528233-readonly-open.patch
Add upstream/573823-imap_internal_date
[software/mutt-debian.git] / debian / patches / upstream / 528233-readonly-open.patch
1 Open attachments as read-only so the editor won't be able to modify it;
2 otherwise the user can believe that he/she can edit it and risk to lose his/her
3 work (see upstream bug http://bugs.mutt.org/3261)
4
5 --- a/attach.c
6 +++ b/attach.c
7 @@ -494,6 +494,7 @@
8         goto return_error;
9      }
10  
11 +    chmod (tempfile, 0400);
12      use_pipe = rfc1524_expand_command (a, tempfile, type,
13                                        command, sizeof (command));
14      use_pager = entry->copiousoutput;