]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/535096-pop-port.patch
Add upstream/573823-imap_internal_date
[software/mutt-debian.git] / debian / patches / upstream / 535096-pop-port.patch
1 This patch will allow the user to specify a port, as it was before 1.5.20, see
2 upstream bug http://bugs.mutt.org/3322
3
4 --- a/pop_lib.c
5 +++ b/pop_lib.c
6 @@ -43,6 +43,7 @@
7    /* Defaults */
8    acct->flags = 0;
9    acct->type = M_ACCT_TYPE_POP;
10 +  acct->port = 0;
11  
12    c = safe_strdup (path);
13    url_parse_ciss (&url, c);
14 @@ -60,10 +61,12 @@
15      acct->flags |= M_ACCT_SSL;
16  
17    service = getservbyname (url.scheme == U_POP ? "pop3" : "pop3s", "tcp");
18 -  if (service)
19 -    acct->port = ntohs (service->s_port);
20 -  else
21 -    acct->port = url.scheme == U_POP ? POP_PORT : POP_SSL_PORT;;
22 +  if (!acct->port) {
23 +    if (service)
24 +      acct->port = ntohs (service->s_port);
25 +    else
26 +      acct->port = url.scheme == U_POP ? POP_PORT : POP_SSL_PORT;;
27 +  }
28  
29    FREE (&c);
30    return 0;