]> git.llucax.com Git - software/mutt-debian.git/blob - debian/patches/upstream/537694-segv-imap-headers.patch
Add upstream/573823-imap_internal_date
[software/mutt-debian.git] / debian / patches / upstream / 537694-segv-imap-headers.patch
1 This patch fixes a segfault that happens when the IMAP server sends some
2 additional flags for the same message ID, see upstream bug
3 http://bugs.mutt.org/3288
4
5 --- a/imap/message.c
6 +++ b/imap/message.c
7 @@ -288,7 +288,7 @@
8          continue;
9        }
10        /* May receive FLAGS updates in a separate untagged response (#2935) */
11 -      if (idx < ctx->msgcount)
12 +      if (ctx->hdrs[idx] != NULL)
13        {
14         dprint (2, (debugfile, "imap_read_headers: message %d is not new\n",
15                     h.sid));